Magazine, Tools & Home Improvement

How to Configure OpenWRT Router as a Repeater?

As an Amazon Associate I earn from qualifying purchases.

OpenWRT is an open and free router operating system that can be installed on many supported router hardware to tickle more power from the end device and expand the range of functions. A functionality that is probably required very often is the use as a repeater and increasing the range of a WLAN network. This taps into the WiFi network of router 1, so to speak, and outputs this to the clients via the second router!

Practical example: A router is located on the ground floor and supplies the ground floor with WiFi. The first floor is also covered with WiFi via this router, but the transmission power is no longer sufficient up to the attic. Now you use a repeater on the first floor, which now takes care of improved WiFi coverage on the first floor and in the attic. If you want to buy the Best Router for OpenWRT then you should know how to choose the best one.

And that’s how it works:

These instructions are carried out via the user interface, but I will post an excerpt from the configuration files towards the end! There are supposed to be people who prefer to work on the command line! 😉

Step 1: Go to Network -> Wifi.

Now you can see the activated Wi-Fi connection for a normal AP!
Here we now need a second connection, which establishes the connection to the “main router.”

The easiest way to do this is to use the software’s scan function!

All available networks will now be displayed! Here you now choose the network you want to connect to!

Now the mask opens, through which you have to enter the password for your main network. Select wan as the firewall zone – as this connection routes further to the outside!

Check settings – save !!

Settings are adopted!

Step 2: Check the firewall rules!

In principle, you can activate everything here!

Step 3: Not a real step – but a little summary again

The normal AP network settings via which the clients log on to router 2, which plays the repeater.

The second WLAN interface, which establishes the connection to the main router!

Finished!
The router with the OpenWRT operating system should now play repeater!

Here are the config files promised above!

/ etc / config / network

config interface ‘loopback’
        option ifname ‘lo’
        option proto ‘static’
        option ipaddr ‘127.0.0.1’
        option netmask ‘255.0.0.0’

config interface ‘lan’
        option ifname ‘eth0’
        option type ‘bridge’
        option proto ‘static’
        option ipaddr ‘192.168.1.1’
        option netmask ‘255.255.255.0’

config interface ‘wwan’
        option proto ‘dhcp’

/ etc / config / wireless

config wifi-device ‘radio0’
        option type ‘mac80211’
        option macaddr ‘6c: e8: 73: d2: 7c: a0’
        option hwmode ’11ng’
        option htmode ‘HT20’
        list ht_capab ‘SHORT-GI-20’
        list ht_capab ‘SHORT -GI-40 ‘
        list ht_capab’ RX-STBC1 ‘
        list ht_capab’ DSSS_CCK-40 ‘
        option txpower’ 27 ‘
        option country’ US ‘
        option channel’ 2 ‘
        option disabled’ 0 ‘

config wifi-iface
        option device ‘radio0’
        option mode ‘ap’
        option ssid ‘ITler-703’
        option network ‘lan’
        option encryption ‘psk2’
        option key ‘itlernet’

config wifi-iface
        option network ‘wwan’
        option ssid ‘ITler’
        option encryption ‘psk2’
        option device ‘radio0’
        option mode ‘sta’
        option bssid ’00: 13: 10: 14: C2: CD ‘
        option key’ itlernet ‘

/ etc / config / firewall

config defaults
        option syn_flood ‘1’
        option input ‘ACCEPT’
        option output ‘ACCEPT’
        option forward ‘ACCEPT’

config zone
        option name ‘lan’
        option input ‘ACCEPT’
        option output ‘ACCEPT’
        option forward ‘ACCEPT’
        option network ‘lan’

config zone
        option name ‘wan’
        option output ‘ACCEPT’
        option masq ‘1’
        option mtu_fix ‘1’
        option input ‘ACCEPT’
        option forward ‘ACCEPT’
        option network ‘wan wwan’

config forwarding
        option src ‘lan’
        option dest ‘wan’

config rule
        option name ‘Allow-DHCP-Renew’
        option src ‘wan’
        option proto ‘udp’
        option dest_port ’68’
        option target ‘ACCEPT’
        option family ‘ipv4’

config rule
        option name ‘Allow-Ping’
        option src ‘wan’
        option proto ‘icmp’
        option icmp_type ‘echo-request’
        option family ‘ipv4’
– firewall 1/92 1%

config rule
        option name ‘Allow-DHCPv6’
        option src ‘wan’
        option proto ‘udp’
        option src_ip ‘fe80 :: / 10’
        option src_port ‘547’
        option dest_ip ‘fe80 :: / 10’
        option dest_port ‘546’
        option family ‘ ipv6 ‘
        option target’ ACCEPT ‘

config rule
        option name ‘Allow-ICMPv6-Input’
        option src ‘wan’
        option proto ‘icmp’
        list icmp_type ‘echo-request’
        list icmp_type ‘echo-reply’
        list icmp_type ‘destination-unreachable’
        list icmp_type ‘packet-too-big ‘
        list icmp_type’ time-exceeded ‘
        list icmp_type’ bad-header ‘
        list icmp_type’ unknown-header-type ‘
        list icmp_type’ router-solicitation ‘
        list icmp_type’ neighbor-solicitation ‘
        list icmp_type’ router-advertisement ‘
        list icmp_type’ neighbor- advertisement ‘
        option limit’ 1000 / sec ‘
        option family’ ipv6 ‘
        option target ‘ACCEPT’

config rule
        option name ‘Allow-ICMPv6-Forward’
        option src ‘wan’
        option dest ‘*’
        option proto ‘icmp’
        list icmp_type ‘echo-request’
        list icmp_type ‘echo-reply’
        list icmp_type ‘destination-unreachable’
        list icmp_type ‘ packet-too-big ‘
        list icmp_type’ time-exceeded ‘
        list icmp_type’ bad-header ‘
        list icmp_type’ unknown-header-type ‘
        option limit’ 1000 / sec ‘
        option family’ ipv6 ‘
        option target’ ACCEPT ‘

config include
        option path ‘/etc/firewall.user’

Tags:

  • openwrt luci repeater configuration
  • Open wrt TP Link repiter
  • open wrt wlan repeater
  • router for open wrt wlan client
  • wlan router openwrt bridge

As an Amazon Associate I earn from qualifying purchases.

Leave a Comment

Your email address will not be published. Required fields are marked *

*

This site uses Akismet to reduce spam. Learn how your comment data is processed.